]> git.pld-linux.org Git - packages/libpq++.git/blob - libpq++.spec
- updated URLs
[packages/libpq++.git] / libpq++.spec
1 Summary:        Older implementation of C++ interface to PostgreSQL
2 Summary(pl.UTF-8):      Starsza implementacja interfejsu C++ do PostgreSQL
3 Name:           libpq++
4 Version:        4.0
5 Release:        5
6 License:        BSD
7 Group:          Libraries
8 Source0:        https://ftp.postgresql.org/pub/projects/gborg/libpqpp/stable/%{name}-%{version}.tar.gz
9 # Source0-md5:  da71cb79ef45cef55f4bc97a33a0857d
10 Patch0:         %{name}-make.patch
11 Patch1:         %{name}-libdir.patch
12 Patch2:         include.patch
13 URL:            https://www.postgresql.org/docs/7.0/libpqplusplus.htm
14 BuildRequires:  libstdc++-devel
15 BuildRequires:  postgresql-devel >= 7.3
16 Provides:       postgresql-c++
17 Obsoletes:      postgresql-c++
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 This package includes library for C++ interface to PostgreSQL. It's
22 an older implementation, included with PostgreSQL up to 7.2.x.
23
24 %description -l pl.UTF-8
25 Pakiet ten zawiera biblioteki dla interfejsu C++ do PostgreSQL. Jest
26 to starsza implementacja, dołączana do PostgreSQL-a aż do 7.2.x.
27
28 %package devel
29 Summary:        Older C++ interface to PostgreSQL - development part
30 Summary(pl.UTF-8):      Starszy interfejs C++ do PostgreSQL - część programistyczna
31 Group:          Development/Libraries
32 Requires:       %{name} = %{version}-%{release}
33 Requires:       libstdc++-devel
34 Requires:       postgresql-devel
35 Provides:       postgresql-c++-devel
36 Obsoletes:      postgresql-c++-devel
37
38 %description devel
39 This package includes header files for older C++ interface.
40
41 %description devel -l pl.UTF-8
42 Pakiet ten zawiera pliki nagłówkowe dla starszego interfejsu C++.
43
44 %package static
45 Summary:        Older C++ interface to PostgreSQL - static libraries
46 Summary(pl.UTF-8):      Starszy interfejs C++ do PostgreSQL - biblioteki statyczne
47 Group:          Development/Libraries
48 Requires:       %{name}-devel = %{version}-%{release}
49 Provides:       postgresql-c++-static
50 Obsoletes:      postgresql-c++-static
51
52 %description static
53 This package includes static library for older interface C++.
54
55 %description static -l pl.UTF-8
56 Pakiet ten zawiera biblioteki statyczne dla starszego interfejsu C++.
57
58 %prep
59 %setup -q
60 %patch0 -p1
61 %patch1 -p0
62 %patch2 -p1
63
64 %build
65 %{__make} static \
66         POSTGRES_HOME=%{_prefix} \
67         LIBDIR=%{_libdir} \
68         CXX="%{__cxx}" \
69         CXXFLAGS="%{rpmcflags} -Wall"
70
71 %{__rm} *.o
72 %{__make} \
73         POSTGRES_HOME=%{_prefix} \
74         LIBDIR=%{_libdir} \
75         CXX="%{__cxx}" \
76         CXXFLAGS="%{rpmcflags} -Wall -fPIC" \
77         LDFLAGS="%{rpmldflags}"
78
79 %install
80 rm -rf $RPM_BUILD_ROOT
81 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
82
83 %{__make} install \
84         DESTDIR=$RPM_BUILD_ROOT \
85         LIBDIR=%{_libdir} \
86         POSTGRES_HOME=%{_prefix}
87
88 ln -sf libpq++.so.4.0 $RPM_BUILD_ROOT%{_libdir}/libpq++.so.4
89
90 install examples/*.* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
91
92 %clean
93 rm -rf $RPM_BUILD_ROOT
94
95 %post   -p /sbin/ldconfig
96 %postun -p /sbin/ldconfig
97
98 %files
99 %defattr(644,root,root,755)
100 %doc CHANGES README
101 %attr(755,root,root) %{_libdir}/libpq++.so.*.*
102 %attr(755,root,root) %ghost %{_libdir}/libpq++.so.4
103
104 %files devel
105 %defattr(644,root,root,755)
106 %doc docs/*.html
107 %attr(755,root,root) %{_libdir}/libpq++.so
108 %{_includedir}/libpq++.h
109 %{_includedir}/libpq++
110 %{_examplesdir}/%{name}-%{version}
111
112 %files static
113 %defattr(644,root,root,755)
114 %{_libdir}/libpq++.a
This page took 0.096364 seconds and 3 git commands to generate.